You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
🐞 HelmChart kubeVersion field prevents installing Charts on a a pre-release K8S #153
Describe the bug
All SCB HelmCharts contain the kubeVersion field to ensure the K8S version meets the SCB requirements.
Example Operator Chart
apiVersion: v2name: operatordescription: secureCodeBox Operator to automate the execution of security scans on kubernetestype: application# version - gets automatically set to the secureCodeBox release version when the helm charts gets publishedversion: latestkubeVersion: ">=v1.11.0"
The current definition results in an error if the K8S is using a pre-release version, even if its never than the kubeVersion semversion:
helm --namespace securecodebox-system upgrade --install securecodebox-operator secureCodeBox/operator --version v2.0.0-rc.12
Error: UPGRADE FAILED: chart requires kubeVersion: >=v1.11.0 which is incompatible with Kubernetes v1.16.6-beta.0
Expected behavior
It would be great to support Kubernetes pre-release versions. As explained in the helm issue helm/helm#3810 this could be done by adding a pre-release extension to the kube version field:
Solution
apiVersion: v2name: operatordescription: secureCodeBox Operator to automate the execution of security scans on kubernetestype: application# version - gets automatically set to the secureCodeBox release version when the helm charts gets publishedversion: latestkubeVersion: ">=v1.11.0-0"
Activity
Bugfixing helmchart kubeVersion field to accept pre-releases also. fixes
Bugfixing helmchart kubeVersion field to accept pre-releases also. fixes